Skip to content

Pipeline Coverage Packagist Docker License

Composer update check plugin

A Composer Plugin to check outdated packages, based on their requirements.

🚀 Features

  • Find outdated packages
  • Multiple exclusion patterns (ignore packages, skip dev-requirements)
  • Optional security scan
  • Allow integration of additional plugins

🐥 What are the differences to other plugins and commands?

Against other plugins and commands, this Plugin takes the version constraints into account and reports outdated packages based on the individual requirements in your composer.json file.

Example

Given the following requirements of a composer.json file:

{
  "require-dev": {
    "phpunit/phpunit": "~5.1.0"
  }
}

Now compare the output of the native composer outdated command with the output from the composer update-check command provided by this plugin:

Composer outdated

Using the native Composer command composer outdated, one can only check if major or minor version updates are available.

In this case the command output would either show the major update (currently version 9.x.x) or the minor update (currently version 5.7.x).

Reference

Composer update-check

The Composer command composer update-check provided by this plugin allows checking for version updates based on the exact requirements. In this case the output would show an available update to version 5.1.7.

This is basically the same result one would get when running composer update --root-reqs --dry-run.

Additionally, one can explicitly exclude several packages from being checked for available updates or perform an additional security scan for the currently installed package versions.

Let's get started

⭐ License

This project is licensed under GNU General Public License 3.0 (or later).


Last update: 2021-04-06